Register immediately
View: 667|Reply: 3
Print Prev. thread Next thread

AMD Graphic Cards still unavailable to play?!

[Copy link]

1

Threads

1

Posts

5

Credits

Lv.2 Fresh Member

Rank: 1

Credits
5
Jump to specified page
The Landlord
Post time 2020-6-4 15:13:00 | Show the author posts only Reply Awards |Descending |Read mode
Hi! I've played this game since Season 1, I was excited to hear that the game was getting on computer. I've had this issue since the game came on computer and I still receive the same answer:
Identity V on PC is currently available for AMD Graphic Cards, our technical team is trying their best to fix this issue

It's been more than a year. Where is that technical team? Where are the updates about the issues? Why is no one talking about it? Are we irrelevants? Is it too hard to talk to their community about what's going on and why is it happening and how long will it take to fix it?


For everyone wondering what AMD Graphic Cards users have to see when they try to play:





Don't even think about going into a match like this, most of the textures won't load.

When is the update to fix this gonna come?! Is NetEase too busy with other games?!


Reply

Use magic Report

1

Threads

4

Posts

12

Credits

Lv.2 Fresh Member

Rank: 1

Credits
12
The Sofa
Post time 2020-6-5 06:21:20 From the mobile phone | Show the author posts only
I have the same problem before. Please switch to Smooth Mode in the Graphics section and let the game restart. I hope it works. Cause it worked for me.

Comments

ilv!! my game is playable now! Thxx  Post time 2020-10-22 09:25
Reply Support 1 Not support 0

Use magic Report

0

Threads

1

Posts

4

Credits

Lv.2 Fresh Member

Rank: 1

Credits
4
The Bench
Post time 2021-2-15 00:00:30 | Show the author posts only
囚人 replied at 2020-6-5 06:21
I have the same problem before. Please switch to Smooth Mode in the Graphics section and let the gam ...

I have the same problem. I used the integrated graphic card ati radeon 4000 and when I put it on smooth mode, my game just didn't load and close inmediately and automatically, kinda crashing. What I can do?
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register immediately

Points Rules